Aquest procediment explica com fer funcionar la PDI Smart SB480 amb Linux Ubuntu 14 04. Fins fa poc aquest model concret de PDI (la SB480) no funcionava amb Ubuntu 14.04. El problema es resol instal·lant una nova versió del paquet nwfermi i totes les seves dependències. Abans s'ha d'haver instal·lat el paquet libudev0. Tot seguit es mostren les instruccions de com fer-ho.

 

Aquest procediment explica la configuració correcte de la PDI SmartBoard SB480 amb Linux Ubuntu 14 04.

S'ha d'aplicar exclusivament a ordinadors amb Linux Ubuntu 14.04 adquirits pel centre i instal·lats a partir de la ISO de Linux Ubuntu 14.04 distribuïda per la Conselleria, i que han de controlar pissarres digitals de la marca SmartBoard model SB480. Aquestes PDI es poden distingir perquè a la part superior dreta tenen rotulat el text "DViT".
 


Són del model SB480 les PDI distribuïdes en els contractes CONTR-2011-507, CONTR-2011-717 i CONTR-2012-1603. Us recordam, però, que les versions homologades dels PC distribuits per la Conselleria en els diferents contractes es troben a "Pendrives de restauració dels diferents contractes".  Per tant, el procediment descrit en aquest article NO s'ha d'aplicar als ordinadors d'aquests contractes ni de cap altre contracte. En qualsevol cas, està previst, per a les properes setmanes, posar a disposició dels centres l'actualització a Ubuntu 14.04 dels pendrives d'aquests contractes.

 

Procediment

La primera passa que s'ha de fer és instal·lar el programari de les pissarres Smart. Per fer això s'ha de seguir el procediment indicat a l'article "Instal·lació del programari de les PDI SmartBoard en els Ubuntu 14.04".

Un cop instal·lat aquest software i reiniciat l'ordinador, s'ha de tornar iniciar sessió amb l'usuari ubtadmin i obrir un terminal.

Actualitzau les fonts de programari:

sudo apt-get update

En aquest article suposam que la instal·lació de l'Ubuntu 14.04 s'ha fet a partir de la ISO que distribueix la Conselleria: "Ubuntu Live Xarxipèlag a disposició dels centres" Si no s'ha fet així, el procediment explicat a continuació no funcionarà ja que no es trobaran els paquets que s'indiquen.

A un terminal s'han d'executar les ordres següents respectant l'ordre indicat i una darrera l'altre:

sudo apt-get install libudev0

Un cop instal·lat el paquet es pot procedir amb la instal·lació de l'altre:

sudo apt-get install nwfermi

 A més del paquet nwfermi, s'instal·laran altres paquets (dependències).

Un cop acabada la instal·lació, es necessari activar el "Mode d'ús simultani del ratolí" (SMART Technologies - Configuració d'SMART → Configuració del maquinari d'SMART → Configuració del ratolí i dels moviments) tal i com es mostra a la figura següent:

Mode d'ús simultani del ratolí

Una cop fet això, s'ha de reiniciar.

Ara, si es té connectada una PDI SB480, l'ordenador la detectarà i funcionarà correctament. Es pot procedir a orientar-la i a treballar normalment.

Nota important: 

En actualitzar el nucli de Linux, és necessari reinstal·lar el paquet nwfermi:
sudo apt-get install --reinstall nwfermi