Imprimeix
Categoria: Aula digital
Vist: 5798

Aquest procediment explica com actualitzar les llibreries de Linux Ubuntu 12.04 utilitzades per la PDI SmartBoard model SB480. En concret l'actualització afecta al paquet nwfermi i a totes les seves dependències. S'ha fet una modificació d'aquest paquet que afecta sensiblement al rendiment de la PDI però per qüestions de compatibilitat s'ha hagut de mantenir el número de versió del paquet. Podeu comprovar si teniu aplicada aquesta darrera actualització esbrinant la data de modificació del fitxer nwfermi_daemon:

A un terminal, executa la següent instrucció:
ls -l /usr/sbin/nwfermi_daemon 
S'ha d'aplicar aquesta actualització si la data de modificació d'aquest fitxer és anterior al 21 de novembre de 2012

Aquesta actualització millora les prestacions i l'estabilitat de la PDI SB480 en Linux Ubuntu 12.04. Resol el problema sorgit en algunes instal·lacions que impedia la orientació / calibració de la PDI. És MOLT IMPORTANT aplicar-la.

S'ha d'aplicar exclusivament als ordinadors amb Linux Ubuntu 12.04 que han de controlar pissarres digitals de la marca SmartBoard model SB480. Aquestes PDI es poden distingir perquè a la part superior dreta tenen rotulat el text "DViT".

Són del model SB480 les PDI distribuïdes en els contractes CONTR-2011-507, CONTR-2011-717 i CONTR-2012-1603. Cal assenyalar però que els contractes CONTR-2011-507 i CONTR-2011-717 es varen distribuir amb el sistema Ubuntu 10.04 i que el procediment explicat en aquest article afecta únicament a Ubuntu 12.04
Es pot saber si s'està usant la versió 12.04 executant, en un terminal, l'ordre que proporciona la versió del nucli de Linux que s'està utilitzant:
uname -a
La versió del nucli en la distribució 12.04 d'Ubuntu és del tipus 3.2.0-x 

Actualització/reinstal·lació del paquet nwfermi

A un terminal s'ha d'executar
sudo apt-get update
sudo apt-get install --reinstall nwfermi

Si apareix un error del tipus "No és possible la reinstaŀlació del paquet nwfermi, no es pot baixar." és perquè els repositoris Educaib i Educaib-Priv no estan correctament configurats (això pot passar en alguns PC d'aula que no hagin rebut les configuracions centralitzades). En aquest cas es poden configurar manualment  descarregant els fitxers de configuració des del servidor de descàrregues:
wget -N http://edudownload.caib.es/files/ubt1204/educaib
sudo cp educaib /etc/apt/preferences.d/
wget -N http://edudownload.caib.es/files/ubt1204/educaib-precise.list
sudo cp educaib-precise.list  /etc/apt/sources.list.d/

Un cop fet això s'ha de tornar a executar:
sudo apt-get update
sudo apt-get install --reinstall nwfermi

En el següent reinici la PDI ha de funcionar correctament.