Imprimeix
Categoria: Problemes i solucions
Vist: 10805

Problemes amb els desplegaments automatitzats de configuracions i de nou programari


Mitjançant el servidor de configuracions i fent servir la utilitat puppet es despleguen configuracions i actualitzacions als ordenadors d'aula i als ultraportàtils.

Existeix un servidor de configuracions central i cada centre té un servidor de configuracions que llegeix les configuracióons planificades des del servidor de configuracions central i, a la vegada, les distribueix als ordenadors d'aula i als ultraportàtils del centre.

Els equips clients (ordinadors d'aula i ultraportàtils) es connecten al servidor de configuracions del centre cada 30 minuts per comprovar si hi han noves configuracions per aplicar; per tant caldrà tenir-los com a mínim 30 minuts en marxa perquè s'apliquin les configuracions del puppet. Si no es vol esperar els 30 minuts sempre es pot forçar la descàrrega de configuracions executant, des d'un terminal i amb el compte d'administrador de l'Ubuntu (ubtadmin) l'ordre següent:

sudo puppetd -t


Exemples de configuracions que es despleguen fent servir el servidor de configuracions

 


Errades típiques que ens surten quan executam sudo puppetd -t

 

El client puppet no troba el servidor

Aquesta errada es dóna per no tenir correcte el fitxer puppet.conf
Apereixerà un error similar al que es mostra a les imatges següents:

thumb_errada1

thumb_errada1_2

Solució:al Terminal, executau les següents comandes:

El client puppet no pot arribar al servidor 1a errada

Aquesta errada es dóna per no tenir correcte el fitxer hosts
Apereixerà un error similar al que es mostra a la imatge següent:
 

  thumb_puppet

Solució: revisau i modificau el fitxer /etc/hosts. Per a fer-ho anam al Terminal:

sudo nano /etc/hosts 

i modificau la línia que comença per 127.0.1.1 substituint el nom lxXXXhubt1204 pel nom del equip.


Control + O  per guardar els canvis, Control + X  per sortir del nano
 

El client puppet no pot arribar al servidor 2a errada

Aquesta errada es dóna per no tenir correcte el fitxer nsswitch.conf
Apereixerà un error similar al que es mostra a la imatge següent:

thumb_nsswitch

Solució: anau al Terminal

sudo nano /etc/nsswitch.conf

Hi modificau la línia hosts, de tal manera que quedi així:

hosts:      files dns mdns4_minimal [NOTFOUND=return] mdns4

Control + O  per guardar els canvis, Control + X  per sortir del nano

El client puppet es troba bloquejat

Apareixerà un error similar al que es mostra a la imatge següent:

thumb_errada2

Solució:
esborrau el fitxer de bloqueig mitjançant l'execució al Terminal de:

sudo rm /var/lib/puppet/state/puppetdlock

 

Problemes de concordància amb el certificat SSL del servidor


Aquest error apareix quan s'ha generat un nou certificat en el servidor normalment per caducitat de l'anterior. L'error que apareix quan s'executa puppetd -t  es mostra a la següent imatge:

thumb_errada  

Solució: esborrau el directori que guarda el certificat SSL mitjançant l'execució de: 

sudo rm -rf /var/lib/puppet/ssl

 

En tornar executar sudo puppetd -t  es baixarà el nou certificat des del servidor i ja no han d'apareixer els problemes de concordància.

 

No concorda el certificat ssl de l'ordinador amb el que hi ha al servidor


Normalment, aquest error apareix quan el sistema ha estat restaurat.
Apareixerà un error similar al que es mostra a la imatge següent:

thumb_ssl

Solució:  eliminar el certificat al servidor de configuracions puppet.  Anau a l'article  "Eliminar el certificat del servidor de configuracions puppet".

Les fonts de programari estan desconfigurades


Apareixerà un error similar al que es mostra a la imatge següent:

thumb_Captura_la00365

Solució:
tal i com es recomana a la imatge executau:

sudo dpkg --configure -a

 

Manca la instal·lació de determinats paquets (dependències insatisfetes)


Apareixerà un error similar al que es mostra a la imatge següent:

thumb_Captura-f_install

Solució
: tal i com es recomana a la imatge executau:

sudo apt-get -f install

 

Versió incorrecte del puppet


Apareixerà un error similar al que es mostra a la imatge següent:

thumb_problema_versio

Solució
:
Comprovau la versió del puppet que teniu instal·lada amb

sudo puppetd --version


 problema_versio2


 La versió homologada que funciona correctament és la 0.24.8  Si us apareix la 0.25.4 haureu de realitzar un downgrade amb les següents instruccions:

sudo apt-get update

 

sudo apt-get install puppet

 
Us demanarà si voleu canviar els paràmetres del puppet.conf

thumb_problema_versio3

 
Heu de dir que no 
 

Altres problemes amb el certificat ssl

Apareixen errors similars als que es mostren a les següents imatges:

thumb_errada


thumb_errada_capsalera


Solució: comprovau que la data i l'hora de l'ordinador són correctes i esborrau el certificat ssl mitjançant l'execució de:

 

 sudo rm -rf /var/lib/puppet/ssl


Execució de puppetd -t  una vegada resolt el problema


Un cop esmenat l'error es fa necessari executar un altre cop la instrucció

sudo puppetd -t