Imprimeix
Categoria: Problemes i solucions
Vist: 4835

Darrerament cada vegada que hi ha una actualització de Java els programes que fan servir Java per funcionar, com per exemple el JClic, donen un missatge d'avís i no permeten executar el seu contingut. Això succeeix a causa d'una nova mesura de seguretat en la versió de java instal·lada. Aquest bloqueig afecta als applets de Java que no estan certificats per una autoritat de certificació. Per poder utilitzar aquests applets, us proposem dues solucions. A) Emplenar una llista d'excepcions  B) Baixar el nivell de seguretat.

                                                         SISTEMA OPERATIU 12.04

A) EMPLENAR UNA LLISTA D'EXCEPCIONS


icono_javapanel



security

Si el botó de les excepcions Edit_Site List no surt es deu a que teniu una versió bastant antiga de Java i haurieu d'actualitzar-la si voleu emprar aquest recurs.


site_list

Ara ja podeu executar l'aplicació java, però teniu en compte que vos sortirà un avís de risc de seguretat.

A més si feu servir un navegador, per exemple el firefox, i no teniu actualitzada la versió de java primer de tot sortirà aquesta pantalla:

activa


warning


B) BAIXAR EL NIVELL DE SEGURETAT

Si no voleu emplenar les excepcions dels llocs, una altra opció consisteix en baixar el grau de seguretat a Medium, tal com es pot veure en aquesta imatge:

bajar_medium
Tancau la finestra de Java Control Panel i a partir d'ara les aplicacions Java s'executaràn correctament després d'haver acceptat el risc de seguretat esmentat en la solució A.

Per al sistema operatiu Windows el procediment és el mateix. Només canvia la ubicació del Java plugin Control Panel, el qual es troba en el Tauler de control.
Aquests canvis s'han de fer a nivell d'usuari (és a dir, cada usuari de la màquina ha d'establir el seu nivell de seguretat del Java).