Imprimeix
Categoria: Aula digital
Vist: 454

Aquest procediment explica com instal·lar el programari de les PDI SmartBoard (drivers i Notebook) en el sistema operatiu Ubuntu 14.04. Cal assenyalar que la ISO distribuïda per la Conselleria de l'instal·lador de l'Ubuntu 14.04 no inclou el programari de les pissarres Smart. Només s'inclou aquest programari en les imatges dels ordinadors que es distribueixen juntament amb una PDI de la marca Smart. 

Les versions del programari un cop instal·lades seran:

Drivers: 11.3.2121.1
Notebook: 11.0.7511.0

Aplicat a: PC d'aula amb els sistemes operatius Ubuntu 14.04 (tots els models de les PDI d'Smart).

S'ha d'aplicar exclusivament a ordinadors amb Linux Ubuntu 14.04 adquirits pel centre, instal·lats a partir de la ISO de Linux Ubuntu 14.04 distribuïda per la Conselleria i que han de controlar pissarres digitals de la marca Smart..

 

Us recordam que les versions homologades dels PC distribuits per la Conselleria en els diferents contractes es troben a "Pendrives de restauració dels diferents contractes".  Per tant, el procediment descrit en aquest article NO s'ha d'aplicar als ordinadors d'aquests contractes ni de cap altre contracte. Per actualitzar els ordinadors dels contractes s'ha de sol·licitar o descarregar el pendrive corresponent.

 

Descàrrega del programari


En primer lloc s'explica com descarregar el programari. És convenient guardar el programari descarregat a un suport extern, tipus pendrive. Encara que aquesta descàrrega es podria fer perfectament amb un ordinador amb Windows, les instruccions que tot seguit s'explicaran pressuposen que es treballa en un ordinador amb Linux Ubuntu (pot ser un Linux Ubuntu qualsevol, no és necessari que sigui un dels ordinadors on es vol instal·lar el programari).

Inicia una sessió amb l'usuari administrador de l'Ubuntu (ubtadmin) i obre un terminal

Crea una nova carpeta on s'hi ubicaran els fitxers descarregats:

 mkdir -p smart-v11


Canvia a aquesta carpeta:

 cd smart-v11


Descarrega l'script que gestionarà la descàrrega del programari:

 wget http://edudownload.caib.es/files/smart/ubuntu/download-smart-software-ubuntu-v11sp2.sh


Proporciona permisos d'execució a aquest script:

 chmod 755 download-smart-software-ubuntu-v11sp2.sh


Executa l'script:

 ./download-smart-software-ubuntu-v11sp2.sh


Comença la descàrrega del programari...paciència...

En acabar, copia la carpeta smart-v11, que trobaràs dins la carpeta ubtadmin, a un suport extern (p.e. pendrive)

Instal·lació del programari


Les accions que a continuació s'expliquen ja s'han d'executar als l'ordinadors on s'hi vol instal·lar el programari. Mentre duri la instal·lació és necessari que l'ordinador estigui connectat a INternet.

Procediment:


1. Inicia una sessió com a ubtadmin

2. Introdueix el pendrive que conté el programari descarregat i obri'l amb l'explorador d'arxius (es tracta d'assegurar que el pendrive està muntat)

3. Obri un terminal i canvia al directori del pendrive que conté el programari:

 cd /media/ubtadmin/XXXXX/smart-v11


on XXXXX és nom identificatiu del pendrive

4. Actualitza les fonts de programari:

sudo apt-get update


5. Executa l'ordre següent:

  sudo dpkg -i smart-*.deb


Si dóna un avís "mesage hash not valid", no se n'ha de fer cas.

6. Executau l'ordre següent per instal·lar les dependències no resoltes:

sudo apt-get -f install

 
7. Si el model de PDI NO és el model SB480 DViT, la instal·lació ha acabat. Reiniciau, orientau i procediu a treballar normalment.

8. Si la PDI és una Smart SB480 DViT s'han d'instal·lar uns paquets addicionals:

sudo apt-get install libudev0 nwfermi

 A més d'aquests paquets, se'n instal·laran d'altres com a dependències.

 

Un cop acabada la instal·lació, reiniciau. Abans d'orientar i usar la PDI és necessari activar el "Mode d'ús simultani del ratolí" (SMART Technologies - Configuració d'SMART → Configuració del maquinari d'SMART → Configuració del ratolí i dels moviments) tal i com es mostra a la figura següent (només és necessari en el model SB480 DViT):

 

Mode d'ús simultani del ratolí

 

Ara ja es pot procedir a orientar-la i a treballar normalment.

Nota important: 

En actualitzar el nucli de Linux, és necessari reinstal·lar el paquet nwfermi:

sudo apt-get install --reinstall nwfermi